Start Free Trial

Monitoring MikroTik Routers with NetFlow and Talaia

[fa icon="calendar"] Dec 11, 2015 11:00:00 AM / by Josep Sanjuas

 


Talaia is a cloud-based SaaS network visibility solution that is compatible with any router that implements NetFlow, IPFIX or sFlow (and other wire-compatible protocols). The main advantage of mikrotik routerTalaia is that you don’t need to download, install and maintain a local installation – it just works.

Since MikroTik routers implement NetFlow, they are fully compatible with Talaia. Thus, setting them up is as easy as 1-2-3, and will only take about 5 minutes of your time.

There are three easy steps to set up a MikroTik router with Talaia:

  1. Create a trial instance of Talaia. We will provide you with two important configuration parameters: an IP address, and a port number.
  2. Enable NetFlow in your MikroTik router, using these configuration parameters and the commands below.
  3. Activate your subscription, so that the instance survives the free trial period.

To configure NetFlow, run the following commands (replacing A.B.C.D and P for the IP address and port we will provide you in step 1):


/ip traffic-flow
set active-flow-timeout=1m enabled=yes
/ip traffic-flow target
add dst-address=A.B.C.D port=P v9-template-timeout=1m

And that’s all that is required to get Talaia running from your end!

To verify it is correctly running, check the following commands match their expected output:


[admin@MikroTik] > /ip traffic-flow print
              enabled: yes
           interfaces: all
        cache-entries: 64k
  active-flow-timeout: 1m
inactive-flow-timeout: 15s
[admin@MikroTik] > /ip traffic-flow target print detail
Flags: X - disabled
 0   src-address=0.0.0.0 dst-address=A.B.C.D port=P version=9
     v9-template-refresh=20 v9-template-timeout=1m

Happy network monitoring!

 

Setup Free Trial

 

Written by Josep Sanjuas